Talk on ABI Compatibility in FUDCon, Pune

I am happy and excited to attend FUCon APAC 2015. It is a Fedora user and developer conference with wide varieties of talks on topics like packaging, QA, design, documentation, etc. This year, it is happening in MIT College of Engineering, Pune, India from 26th June to 28th June. Schedule of FUDCon is already up and you can choose in advance what all talks you want to attend. This year, there will be 3 parallel tracks going on as main talks. If you don’t like listening to talks much, then you can go for workshop which is also happening in parallel.

This FUDCon is special to me because it will be my first Fedora conference and on top of it I will be speaking as well on ABI Compatibility . Slides and demo to be shown during talk are already available on github. This talk will walk you through why and how your application could be incompatible with upgrading dependent packages required for your application. Later, introducing to different tools which you can use to avoid using/developing incompatible ABI (Application Binary Interface) in your application. At the end, a demo showing how ABI incompatibility gets introduced in a C library across its two versions, its effect on application consuming that library and how  ABI tools detect that ABI change, will make your understanding even more clear.

See you all during FUDCon!

 

 

Advertisements